Get in touch
Back
Maintenance

Teamspeak server maintenance

Completed 16 May at 11:27pm CEST.

theflyingfather.pl
Completed

Maintenance completed

Posted 16 May at 11:27pm CEST.
Started

The main website may be affected
EDIT: Maintenance ended with some downtime. It is estimated, that up to 3 users could have used the website at that time.

Posted 16 May at 10:15pm CEST.