Completed
Maintenance ended without downtime!
Posted
7 May at 08:27pm CEST.
Started
The mszp.pl website might be unavailable for a short period of time (up to 2 minutes)
Update: completed without downtime
Posted
7 May at 08:15pm CEST.
Maintenance ended without downtime!
The mszp.pl website might be unavailable for a short period of time (up to 2 minutes)
Update: completed without downtime