Get in touch
Back
Maintenance

Websites down for maintenance

Completed 8 Jan at 06:00pm CET.

mszp.pl pomysl.mszp.pl
Completed

Maintenance completed

Posted 8 Jan at 06:00pm CET.
Started

The affected websites will be back up as soon as possible.

Posted 6 Jan at 12:00pm CET.